Jump to content

Welcome to Xbox-Vibes

Sign In Register
Search In
  • More options...
Find results that contain...
Find results in...

🇬🇧Xbox series X stuck on “Who’s playing today”


Go to solution Solved by SweetButPhysco12,

Recommended Posts

My sons Xbox (series X) stuck on ”Who’s playing today”. We’ve tried to sing out and back in but now it’s a permanent message. We can’t move onto next page as controller not responding. We tried resyncing controller with console as well as new batteries, nothing works. 
What we can try next please?

 

 

 

What can I do next please?

Link to comment
Share on other sites

  • Premium
  • Solution

@MomOf2

Try this 

 

  • Shut down the console by pressing Power Button
  • When console turns off release the Power Button.
  • Unplug power cable and wait 5 minutes.
  • Plug it back and turn the console back on by pressing the power button.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...