Jump to content

Welcome to Xbox-Vibes

Sign In Register
Search In
  • More options...
Find results that contain...
Find results in...

🇬🇧 Controller Xbox One S not working after charging?


Hassanaq
 Share

Go to solution Solved by Jack,

Recommended Posts

Hello my friends. Last night one of my controller completely discharged it self after long playing Battlefield 2042 and after putting on charge this morning not working. I mean I cant use with the console, nothing. Its definitely power as I can see the light. Please help my friends.

Link to comment
Share on other sites

  • Solution

Have you tried to sync the controller and console back again. This is the common issue when the controllers are completely flat.

To sync them back again keep pressing the sync button on the controller ans console so the lights will start flashing and eventually will stop.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...